帮助

配置静态 IP

如果服务器时常无故无法访问,日志中也没有任何错误记录,问题可能在于服务器 IP 地址“丢失”。原因是服务器创建时被分配的是动态地址,该地址设有“租期”。在租期到期之前,服务器需要重新申请地址(DHCP 会自动分配同一个 IP)。但某些 Linux 发行版申请地址的时间稍晚(租期已经到期),导致地址暂时丢失。此问题最常出现在运行 CentOS 操作系统的服务器上。

要解决此问题,需要在服务器上配置静态 IP。

CentOS

需要在配置文件 /etc/sysconfig/network-scripts/ifcfg-eth0 中进行设置。

1. 使用文本编辑器打开该文件:

nano /etc/sysconfig/network-scripts/ifcfg-eth0

2.1. 将 BOOTPROTO 参数的值从 dhcp 改为 static:

BOOTPROTO=static

2.2. 另外添加以下几行:

IPADDR=%SERVER_IP% 
NETMASK=255.255.255.0 
GATEWAY=%IP_FIRST_3_OCTETS.1%

以地址 188.225.78.45 为例的配置:

NAME="eth0"
ONBOOT=yes
NETBOOT=yes
IPV6INIT=yes
BOOTPROTO=static
TYPE=Ethernet
DEFROUTE=yes
IPV4_FAILURE_FATAL=no
IPV6_AUTOCONF=yes
IPV6_DEFROUTE=yes
IPV6_FAILURE_FATAL=no
PEERDNS=yes
PEERROUTES=yes
IPV6_PEERDNS=yes
IPV6_PEERROUTES=yes
IPADDR=188.225.78.45
NETMASK=255.255.255.0
GATEWAY=188.225.78.1

保存所做的更改。

3. 使用以下命令重启服务:

service network restart

4. 使用以下命令检查结果:

ifconfig

命令输出的 eth0 inet 部分中应显示您配置的 IP 地址:

配置静态 IP

5. 确认 resolv.conf 文件中至少配置了一个 DNS 服务器。打开该文件:

nano /etc/resolv.conf

该文件中很可能已经有以下记录:

nameserver 8.8.8.8

如果没有此记录,请将其添加到文件中并保存更改。

BitrixVM

  1. 在 Bitrix 菜单中选择:2. 管理 localhost -> 3. 手动配置网络接口。
  2. 填写以下参数:
  • Enter you choise interface: eth0
  • Type IP address: %SERVER_IP%(例如:188.225.78.45)
  • Type broadcast: %IP_FIRST_3_OCTETS.255%(例如:188.225.78.255)
  • Type network mask: 255.255.255.0
  • Type default gateway: %IP_FIRST_3_OCTETS.1%(例如:188.225.78.1)
  • Would you like to configure DNS server: y
  • Enter DNS server addresses: 8.8.8.8 8.8.4.4
  • Save change: y
  1. 使用以下命令检查结果:
ifconfig

确认命令输出的 eth0 inet 部分中显示的是您配置的 IP 地址。

Debian / Ubuntu 14, 16

需要在配置文件 /etc/network/interfaces 中进行设置。

1. 使用文本编辑器打开该文件:

nano /etc/network/interfaces

2. 找到 “The primary network interface” 部分,填写以下参数,替换原有的值:

auto eth0 
iface eth0 inet static 
address %SERVER_IP% 
netmask 255.255.255.0 
gateway %IP_FIRST_3_OCTETS.1%

以地址 188.225.78.45 为例的配置:

# The primary network interface 
auto eth0 
iface eth0 inet static 
address 188.225.78.45 
netmask 255.255.255.0 
gateway 188.225.78.1

保存所做的更改。

3. 使用以下命令重启服务:

service networking restart

4. 使用以下命令检查结果:

ifconfig

确认命令输出的 eth0 inet 部分中显示的是您配置的 IP 地址:

配置静态 IP

5. 检查 resolv.conf 文件中是否至少配置了一个 DNS 服务器。打开该文件:

nano /etc/resolv.conf

该文件中很可能已经有以下记录:

nameserver 8.8.8.8

如果没有此记录,请将其添加到文件中并保存更改:

nameserver 8.8.8.8

Ubuntu 18.04, 20.04

在 Ubuntu 18.04 和 20.04 中,网络设置位于 /etc/netplan/01-netcfg.yaml 文件中。

1. 使用文本编辑器打开该文件:

nano /etc/netplan/01-netcfg.yaml

2. 对文件进行以下修改,替换原有的设置:

network: 
  version: 2 
  renderer: networkd 
  ethernets: 
     eth0: 
        dhcp4: no 
        addresses: [%SERVER_IP%/24] 
        gateway4: %IP_FIRST_3_OCTETS.1% 
        nameservers: 
           addresses: [8.8.8.8, 8.8.4.4]

请注意!务必保持文件的层级结构,每一级新的指令都应以两个空格开头(不要使用 Tab 缩进)。

以 IP 地址 188.225.78.45 为例的配置:

network: 
  version: 2 
  renderer: networkd 
  ethernets: 
     eth0: 
        dhcp4: no 
        addresses: [188.225.78.45/24] 
        gateway4: 188.225.78.1 
        nameservers: 
           addresses: [8.8.8.8, 8.8.4.4]

如果需要指定多个 IP 地址,可以采用以下方式:

addresses: [188.225.78.45/24, "2a03:6f00:5:1::X:X/64"]

或者

addresses: 
   - 188.225.78.45/24
   - 2a03:6f00:5:1::X:X/64

保存所做的更改。

3. 执行以下命令检查配置:

netplan try

如果配置没有错误,系统会提示您应用新设置,直接按 Enter 键即可。

也可以使用以下命令立即应用更改:

netplan apply

如有任何疑问,请联系我们